error when starting PUMA Printer Monitor Service

Jul 7, 2009 at 2:59 PM

Hello,

I have a little (maybe a big) problem with PUMA. I installed the necessary SQL-database, I installed the Puma Manager and I installed the service.

But now when i'm trying to start the service i get the following error:

An unhandled exception ('System.Net.Sockets.SocketException') occured in PrinterMonitorService.exe [132].
Just-In-Time debugging this exception failed with the following error: No installed debugger has Just-In-Time
debugging enabled.

And this is the error in the event viewer:
Event Type: Error
Event Source: .NET Runtime 2.0 Error Reporting
Event ID: 5000
Description:
EventType clr20r3, P1 printermonitorservice.exe, P2 1.5.2375.36477, P3 44a97be5, P4 system, P5 2.0.0.0, P6 4889de7a,
P7 2c0b, P8 40, P9 system.net.sockets.socket, P10 NIL.

 

Can somebody help me solve this problem?

Coordinator
Jul 7, 2009 at 8:58 PM

The only bit that uses the 'System.Net.Sockets' namespace is the Spoolfile parsing stuff....which I thought had been removed.

Your best bet is probably to get the source code and compile that to make sure you have the most recent apps.  Otherwise try changing/removing the config entries for 

TransportProtocol, Port and ReturnPort

Jul 8, 2009 at 11:16 AM
Edited Jul 8, 2009 at 12:38 PM

Thanks for your reply.

Ok i have downloaded the newest version from here and compiled that on my server. The service is running fine now and i'm not getting any errors anymore. So that worked out fine.

But now i'm having another problem, I'm starting the Printer Usage Monitoring Management Console and I can add the server as a printserver but I don't see any of the printers installed on the server? Do i have to do something else before you can see all the printers on the printserver? Or do you have to see automatically all the printers in the view?

I have installed the sql tables so that won't be the problem.

Hope you can help me again...

 

Edit: When i added a server in the Management Console app I can then add in the right white field a new printer but then I get this error:

Could not load file or assembly 'PrinterQueueWatch, Version=2.0.7.17941, Culture=neutral,PublicKeyToken=null' or one of its dependencies.

When i compiled the management console i addes the printerqueuewatch.dll to the references (only version 2.0.4.33229) and i copied that file to the server's framework folder.

Is it maybe the printqueuewatch.dll file that is older?

No the printqueuewatch.dll file isn't the problem I updated the file on the server with version 2.0.7.35178 and I still have the problem.